#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\/(sites\/?)?(.*)$"
Local $sString = "/sites/global" & @CRLF & _
"/page/file.ext" & @CRLF & _
"/sites/other" & @CRLF & _
"/page.ext" & @CRLF & _
"/intranet/global" & @CRLF & _
"http://intranet/global"
Local $sSubst = "/sites/\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)