use strict;
my $str = '/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/global';
my $regex = qr/^\/(sites\/?)?(.*)$/mp;
my $subst = '/sites/\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";