using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/(sites\/?)?(.*)$";
string substitution = @"/sites/\2";
string input = @"/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/global";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}