package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/(sites\/?)?(.*)$`)
var str = `/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/global`
var substitution = "/sites/\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}