$re = '/^\/(sites\/?)?(.*)$/m';
$str = '/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/global';
$subst = "/sites/\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;