using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*\@AlternateMessage\({\s*(\""[^""]*\""\s*,?\s*)+}\)\n";
string substitution = @"";
string input = @" @Default(""Stock ()"")
String Stock(int count);
@DefaultMessage(""Assign()"")
@AlternateMessage({
""({})"", ""Assign""
})
String Assign(@PluralCount int count);
@DefaultMessage(""Assign()"")
@AlternateMessage({
""({})"", ""Assign"",
""=0"", ""{0} Assign definitions""
})
String Assign(@PluralCount int count);
@DefaultMessage(""Form"")
String Form();";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}