use strict;
my $str = ' @Default("Stock ()")
String Stock(int count);
@DefaultMessage("Assign()")
@AlternateMessage({
"({})", "Assign"
})
String Assign(@PluralCount int count);
@DefaultMessage("Assign()")
@AlternateMessage({
"({})", "Assign",
"=0", "{0} Assign definitions"
})
String Assign(@PluralCount int count);
@DefaultMessage("Form")
String Form();';
my $regex = qr/^\s*\@AlternateMessage\({\s*(\"[^"]*\"\s*,?\s*)+}\)\n/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";