const regex = /^\s*\@AlternateMessage\({\s*(\"[^"]*\"\s*,?\s*)+}\)\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*\\@AlternateMessage\\({\\s*(\\"[^"]*\\"\\s*,?\\s*)+}\\)\\n', 'gm')
const str = ` @Default("Stock ()")
String Stock(int count);
@DefaultMessage("Assign()")
@AlternateMessage({
"({})", "Assign"
})
String Assign(@PluralCount int count);
@DefaultMessage("Assign()")
@AlternateMessage({
"({})", "Assign",
"=0", "{0} Assign definitions"
})
String Assign(@PluralCount int count);
@DefaultMessage("Form")
String Form();`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);