// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^\s*\@AlternateMessage\({\s*(\"[^"]*\"\s*,?\s*)+}\)\n"#).unwrap();
let string = " @Default(\"Stock ()\")
String Stock(int count);
@DefaultMessage(\"Assign()\")
@AlternateMessage({
\"({})\", \"Assign\"
})
String Assign(@PluralCount int count);
@DefaultMessage(\"Assign()\")
@AlternateMessage({
\"({})\", \"Assign\",
\"=0\", \"{0} Assign definitions\"
})
String Assign(@PluralCount int count);
@DefaultMessage(\"Form\")
String Form();";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}