import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\@AlternateMessage\\(\\{\\s*(\\\"[^\"]*\\\"\\s*,?\\s*)+\\}\\)\\n";
final String string = " @Default(\"Stock ()\")\n"
+ " String Stock(int count);\n\n"
+ " @DefaultMessage(\"Assign()\")\n"
+ " @AlternateMessage({\n"
+ " \"({})\", \"Assign\"\n"
+ " })\n"
+ " String Assign(@PluralCount int count);\n\n"
+ " @DefaultMessage(\"Assign()\")\n"
+ " @AlternateMessage({\n"
+ " \"({})\", \"Assign\",\n"
+ " \"=0\", \"{0} Assign definitions\"\n"
+ " })\n"
+ " String Assign(@PluralCount int count);\n\n"
+ " @DefaultMessage(\"Form\")\n"
+ " String Form();";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}