re = /^\s*\@AlternateMessage\({\s*(\"[^"]*\"\s*,?\s*)+}\)\n/m
str = ' @Default("Stock ()")
String Stock(int count);
@DefaultMessage("Assign()")
@AlternateMessage({
"({})", "Assign"
})
String Assign(@PluralCount int count);
@DefaultMessage("Assign()")
@AlternateMessage({
"({})", "Assign",
"=0", "{0} Assign definitions"
})
String Assign(@PluralCount int count);
@DefaultMessage("Form")
String Form();'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result