# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*\@AlternateMessage\({\s*(\"[^\"]*\"\s*,?\s*)+}\)\n"
test_str = (" @Default(\"Stock ()\")\n"
" String Stock(int count);\n\n"
" @DefaultMessage(\"Assign()\")\n"
" @AlternateMessage({\n"
" \"({})\", \"Assign\"\n"
" })\n"
" String Assign(@PluralCount int count);\n\n"
" @DefaultMessage(\"Assign()\")\n"
" @AlternateMessage({\n"
" \"({})\", \"Assign\",\n"
" \"=0\", \"{0} Assign definitions\"\n"
" })\n"
" String Assign(@PluralCount int count);\n\n"
" @DefaultMessage(\"Form\")\n"
" String Form();")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.