import Foundation
let pattern = #"^\s*\@AlternateMessage\({\s*(\"[^"]*\"\s*,?\s*)+}\)\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
@Default("Stock ()")
String Stock(int count);
@DefaultMessage("Assign()")
@AlternateMessage({
"({})", "Assign"
})
String Assign(@PluralCount int count);
@DefaultMessage("Assign()")
@AlternateMessage({
"({})", "Assign",
"=0", "{0} Assign definitions"
})
String Assign(@PluralCount int count);
@DefaultMessage("Form")
String Form();
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)