# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\*?\d(?:\d\.\d\d?|\d?\.\d)/<span style="color:yellow">$0<\/span>/g;t' <<< "*10.00 5.0 *1 5m"