import Foundation
let pattern = #"\*?\d(?:\d\.\d\d?|\d?\.\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"*10.00 5.0 *1 5m"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span style="color:yellow">$0</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)