import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\*?\\d(?:\\d\\.\\d\\d?|\\d?\\.\\d)";
final String string = "*10.00 5.0 *1 5m";
final String subst = "<span style=\"color:yellow\">$0</span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}