package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\*?\d(?:\d\.\d\d?|\d?\.\d)`)
var str = `*10.00 5.0 *1 5m`
var substitution = "<span style="color:yellow">$0</span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}