const regex = /\*?\d(?:\d\.\d\d?|\d?\.\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\*?\\d(?:\\d\\.\\d\\d?|\\d?\\.\\d)', 'g')
const str = `*10.00 5.0 *1 5m`;
const subst = `<span style="color:yellow">$0</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);