using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*?\d(?:\d\.\d\d?|\d?\.\d)";
string substitution = @"<span style=""color:yellow"">$0</span>";
string input = @"*10.00 5.0 *1 5m";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}