re = /\*?\d(?:\d\.\d\d?|\d?\.\d)/
str = '*10.00 5.0 *1 5m'
subst = '<span style="color:yellow">$0</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result