#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\*?\d(?:\d\.\d\d?|\d?\.\d)"
Local $sString = "*10.00 5.0 *1 5m"
Local $sSubst = "<span style="color:yellow">$0</span>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)