// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\*?\d(?:\d\.\d\d?|\d?\.\d)").unwrap();
let string = "*10.00 5.0 *1 5m";
let substitution = "<span style=\"color:yellow\">$0</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}