use strict;
my $str = '*10.00 5.0 *1 5m';
my $regex = qr/\*?\d(?:\d\.\d\d?|\d?\.\d)/p;
my $subst = '<span style="color:yellow">$0</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";