$re = '/\*?\d(?:\d\.\d\d?|\d?\.\d)/';
$str = '*10.00 5.0 *1 5m';
$subst = "<span style=\"color:yellow\">$0</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;