# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<!--.*?-->)|(<!--[\S\s]+?-->)|(<!--[\S\s]*?$)//g;t' <<< "<!-- single-line -->
<!-- <!-- nested single-line -->
not a comment
<!--
<!-- nested multiline
-->
<!--
multiline
-->
<!-- truncated"