package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<!--.*?-->)|(<!--[\S\s]+?-->)|(<!--[\S\s]*?$)`)
var str = `<!-- single-line -->
<!-- <!-- nested single-line -->
not a comment
<!--
<!-- nested multiline
-->
<!--
multiline
-->
<!-- truncated`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}