import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<!--.*?-->)|(<!--[\\S\\s]+?-->)|(<!--[\\S\\s]*?$)";
final String string = "<!-- single-line -->\n"
+ "<!-- <!-- nested single-line -->\n"
+ "not a comment\n"
+ "<!--\n"
+ " <!-- nested multiline\n"
+ "-->\n"
+ " <!--\n"
+ " multiline\n"
+ " -->\n"
+ " <!-- truncated";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}