import Foundation
let pattern = #"(<!--.*?-->)|(<!--[\S\s]+?-->)|(<!--[\S\s]*?$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<!-- single-line -->
<!-- <!-- nested single-line -->
not a comment
<!--
<!-- nested multiline
-->
<!--
multiline
-->
<!-- truncated
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)