const regex = /(<!--.*?-->)|(<!--[\S\s]+?-->)|(<!--[\S\s]*?$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<!--.*?-->)|(<!--[\\S\\s]+?-->)|(<!--[\\S\\s]*?$)', 'g')
const str = `<!-- single-line -->
<!-- <!-- nested single-line -->
not a comment
<!--
<!-- nested multiline
-->
<!--
multiline
-->
<!-- truncated`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);