$re = '/(<!--.*?-->)|(<!--[\S\s]+?-->)|(<!--[\S\s]*?$)/';
$str = '<!-- single-line -->
<!-- <!-- nested single-line -->
not a comment
<!--
<!-- nested multiline
-->
<!--
multiline
-->
<!-- truncated';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;