import re
regex = re.compile(r"(<!--.*?-->)|(<!--[\S\s]+?-->)|(<!--[\S\s]*?$)")
test_str = ("<!-- single-line -->\n"
"<!-- <!-- nested single-line -->\n"
"not a comment\n"
"<!--\n"
" <!-- nested multiline\n"
"-->\n"
" <!--\n"
" multiline\n"
" -->\n"
" <!-- truncated")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)