use strict;
my $str = '<!-- single-line -->
<!-- <!-- nested single-line -->
not a comment
<!--
<!-- nested multiline
-->
<!--
multiline
-->
<!-- truncated';
my $regex = qr/(<!--.*?-->)|(<!--[\S\s]+?-->)|(<!--[\S\s]*?$)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";