using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\);\s*$";
string substitution = @"\)\);";
string input = @"(""{scriptid}_*0123_00000000_ABC-Description*"");
(""{scriptid}_4-digits_8-alphanumeric_X-alphanumeric-description"");
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}