re = /\);\s*$/m
str = '("{scriptid}_*0123_00000000_ABC-Description*");
("{scriptid}_4-digits_8-alphanumeric_X-alphanumeric-description");
'
subst = '\\)\\);'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result