import re
regex = re.compile(r"\);\s*$", flags=re.MULTILINE)
test_str = ("(\"{scriptid}_*0123_00000000_ABC-Description*\");\n\n"
"(\"{scriptid}_4-digits_8-alphanumeric_X-alphanumeric-description\");\n")
subst = "\\)\\);"
result = regex.sub(subst, test_str)
if result:
print(result)