use strict;
my $str = '("{scriptid}_*0123_00000000_ABC-Description*");
("{scriptid}_4-digits_8-alphanumeric_X-alphanumeric-description");
';
my $regex = qr/\);\s*$/mp;
my $subst = '\\)\\);';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";