// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\);\s*$").unwrap();
let string = "(\"{scriptid}_*0123_00000000_ABC-Description*\");
(\"{scriptid}_4-digits_8-alphanumeric_X-alphanumeric-description\");
";
let substitution = "\\)\\);";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}