# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*name=".+_)\d+(_[^"]+".*)/$1!NEW_ID!$2/gm;t' <<< "some_data_before name=\"some_text_0_some_text\" and then some_data after"