use strict;
my $str = 'some_data_before name="some_text_0_some_text" and then some_data after';
my $regex = qr/(.*name=".+_)\d+(_[^"]+".*)/mp;
my $subst = '$1!NEW_ID!$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";