import Foundation
let pattern = #"(.*name=".+_)\d+(_[^"]+".*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"some_data_before name="some_text_0_some_text" and then some_data after"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1!NEW_ID!$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)