#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*name=".+_)\d+(_[^"]+".*)"
Local $sString = "some_data_before name="some_text_0_some_text" and then some_data after"
Local $sSubst = "$1!NEW_ID!$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)