re = /(.*name=".+_)\d+(_[^"]+".*)/m
str = 'some_data_before name="some_text_0_some_text" and then some_data after'
subst = '$1!NEW_ID!$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result