const regex = /(.*name=".+_)\d+(_[^"]+".*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*name=".+_)\\d+(_[^"]+".*)', 'gm')
const str = `some_data_before name="some_text_0_some_text" and then some_data after`;
const subst = `$1!NEW_ID!$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);