import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*name=\".+_)\\d+(_[^\"]+\".*)";
final String string = "some_data_before name=\"some_text_0_some_text\" and then some_data after";
final String subst = "$1!NEW_ID!$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}