// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(.*name=".+_)\d+(_[^"]+".*)"#).unwrap();
let string = "some_data_before name=\"some_text_0_some_text\" and then some_data after";
let substitution = "$1!NEW_ID!$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}