using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*name="".+_)\d+(_[^""]+"".*)";
string substitution = @"$1!NEW_ID!$2";
string input = @"some_data_before name=""some_text_0_some_text"" and then some_data after";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}