package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*name=".+_)\d+(_[^"]+".*)`)
var str = `some_data_before name="some_text_0_some_text" and then some_data after`
var substitution = "$1!NEW_ID!$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}