# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\sHello\s/ HI /ig;t' <<< "<some tag> <some_nested_tag attr=\"Hello\"> Text </some_nested_tag> Hello world Hello Programming </some tag>"