re = /\sHello\s/i
str = '<some tag> <some_nested_tag attr="Hello"> Text </some_nested_tag> Hello world Hello Programming </some tag>'
subst = ' HI '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result