import re
regex = re.compile(r"\sHello\s", flags=re.IGNORECASE)
test_str = "<some tag> <some_nested_tag attr=\"Hello\"> Text </some_nested_tag> Hello world Hello Programming </some tag>"
subst = " HI "
result = regex.sub(subst, test_str)
if result:
print(result)